ActiveDelphi - Índice do Fórum ActiveDelphi
.: O site do programador Delphi! :.
 
 FAQFAQ   PesquisarPesquisar   MembrosMembros   GruposGrupos   RegistrarRegistrar 
 PerfilPerfil   Entrar e ver Mensagens ParticularesEntrar e ver Mensagens Particulares   EntrarEntrar 

[RESOLVIDO]Delphi não esta pegando alterações feitas

 
Novo Tópico   Responder Mensagem    ActiveDelphi - Índice do Fórum -> Mobile com Delphi
Exibir mensagem anterior :: Exibir próxima mensagem  
Autor Mensagem
eduardoserrao
Novato
Novato


Registrado: Segunda-Feira, 28 de Novembro de 2016
Mensagens: 77

MensagemEnviada: Seg Mar 25, 2019 9:07 am    Assunto: [RESOLVIDO]Delphi não esta pegando alterações feitas Responder com Citação

Bom dia,
Tenho um formulário que não atualiza as alterações que eu faço!
Por exemplo, tenho um botão nesse formulário que tem um showmessage('1); se eu alterar pra showmessage('teste'), continua exibindo 1, tentei colocar um trectangle também pra ver se na parte visual estava atualizando e nada também, tirei e coloquei o formulário do projeto e nada também! nenhuma alteração aparece na hora de executar.

Alguém já passou por isso? como faço para resolver


Editado pela última vez por eduardoserrao em Seg Mar 25, 2019 6:21 pm, num total de 1 vez
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular
marcelo_tux
Aprendiz
Aprendiz


Registrado: Terça-Feira, 2 de Abril de 2013
Mensagens: 230
Localização: São José do Rio Preto - SP

MensagemEnviada: Seg Mar 25, 2019 9:16 am    Assunto: Re: Delphi não esta pegando alterações feitas Responder com Citação

eduardoserrao escreveu:
Bom dia,
Tenho um formulário que não atualiza as alterações que eu faço!
Por exemplo, tenho um botão nesse formulário que tem um showmessage('1); se eu alterar pra showmessage('teste'), continua exibindo 1, tentei colocar um trectangle também pra ver se na parte visual estava atualizando e nada também, tirei e coloquei o formulário do projeto e nada também! nenhuma alteração aparece na hora de executar.

Alguém já passou por isso? como faço para resolver


Bom dia.
Você já deu um clear e/ou um build na sua aplicação ? Isso acontecia comigo sempre. Comecei a sempre antes de compilar minha aplicação para o dispositivo fazer o build, acabaram os problemas.

Espero ter ajudado.
_________________
Porgramador Delphi - Mobile
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular Enviar E-mail
eduardoserrao
Novato
Novato


Registrado: Segunda-Feira, 28 de Novembro de 2016
Mensagens: 77

MensagemEnviada: Seg Mar 25, 2019 9:22 am    Assunto: Re: Delphi não esta pegando alterações feitas Responder com Citação

marcelo_tux escreveu:

Bom dia.
Você já deu um clear e/ou um build na sua aplicação ? Isso acontecia comigo sempre. Comecei a sempre antes de compilar minha aplicação para o dispositivo fazer o build, acabaram os problemas.

Espero ter ajudado.


sim sim, clean, build, compile. nada deu certo :/
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular
eduardoserrao
Novato
Novato


Registrado: Segunda-Feira, 28 de Novembro de 2016
Mensagens: 77

MensagemEnviada: Seg Mar 25, 2019 9:22 am    Assunto: Re: Delphi não esta pegando alterações feitas Responder com Citação

marcelo_tux escreveu:

Bom dia.
Você já deu um clear e/ou um build na sua aplicação ? Isso acontecia comigo sempre. Comecei a sempre antes de compilar minha aplicação para o dispositivo fazer o build, acabaram os problemas.

Espero ter ajudado.


sim sim, clean, build, compile. nada deu certo :/
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular
strak2012
Colaborador
Colaborador


Registrado: Segunda-Feira, 13 de Janeiro de 2014
Mensagens: 1505
Localização: Maceió - AL

MensagemEnviada: Seg Mar 25, 2019 9:57 am    Assunto: Responder com Citação

Simples delete a pasta android do seu projeto, provavelmente apk estar bloqueado para escrita ou sendo usado pelo sistema ou outra aplicação.

Recomendação é ter um anti vírus instalado, pois a maioria deste problema pode ser ocasionado por vírus que ficam monitorando seus arquivos.
_________________
Tudo podemos quando tudo sabemos!
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular Enviar E-mail Visitar a homepage do Usuário MSN Messenger
eduardoserrao
Novato
Novato


Registrado: Segunda-Feira, 28 de Novembro de 2016
Mensagens: 77

MensagemEnviada: Seg Mar 25, 2019 10:56 am    Assunto: Responder com Citação

strak2012 escreveu:
Simples delete a pasta android do seu projeto, provavelmente apk estar bloqueado para escrita ou sendo usado pelo sistema ou outra aplicação.

Recomendação é ter um anti vírus instalado, pois a maioria deste problema pode ser ocasionado por vírus que ficam monitorando seus arquivos.


Excluir a pasta android onde é gerado meu .apk certo? Já tentei também mas não funcionou, o estranho é que fiz um teste alterando o código em outro formulário pra ver se o projeto todo estava assim, e no outro formulário pegou normal as alterações, o problema parece ser nesse meu formulário em especifico :/
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular
strak2012
Colaborador
Colaborador


Registrado: Segunda-Feira, 13 de Janeiro de 2014
Mensagens: 1505
Localização: Maceió - AL

MensagemEnviada: Seg Mar 25, 2019 2:43 pm    Assunto: Responder com Citação

Se clean, build e deletar a pasta android não resolveu, e segundo seu relato criando um novo formulário e fazendo o mesmo teste funciona, então a conclusão que tenho é se você por acaso não teria dois formulário iguais no projeto e estar a alterar um pensando que o que estar sendo exibido, logo por isso na aplicação não surge efeito?

Parece um erro bem besta que é possível de se cometido.
O mesmo tambem se aplica ao trabalhar com frames.
_________________
Tudo podemos quando tudo sabemos!
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular Enviar E-mail Visitar a homepage do Usuário MSN Messenger
eduardoserrao
Novato
Novato


Registrado: Segunda-Feira, 28 de Novembro de 2016
Mensagens: 77

MensagemEnviada: Seg Mar 25, 2019 5:17 pm    Assunto: Responder com Citação

strak2012 escreveu:
Se clean, build e deletar a pasta android não resolveu, e segundo seu relato criando um novo formulário e fazendo o mesmo teste funciona, então a conclusão que tenho é se você por acaso não teria dois formulário iguais no projeto e estar a alterar um pensando que o que estar sendo exibido, logo por isso na aplicação não surge efeito?

Parece um erro bem besta que é possível de se cometido.
O mesmo tambem se aplica ao trabalhar com frames.


Oi Strak2012, foi bobeira minha mesmo, acabei de ver que tinha uma tab com a mema estrutura visual do meu form, eu achei que estava sendo chamado ele, mas estava chamando a tab por isso não aparecia as alterações kkk obrigado pelo ajuda.
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular
Mostrar os tópicos anteriores:   
Novo Tópico   Responder Mensagem    ActiveDelphi - Índice do Fórum -> Mobile com Delphi Todos os horários são GMT - 3 Horas
Página 1 de 1

 
Ir para:  
Enviar Mensagens Novas: Proibido.
Responder Tópicos Proibido
Editar Mensagens: Proibido.
Excluir Mensagens: Proibido.
Votar em Enquetes: Proibido.


Powered by phpBB © 2001, 2005 phpBB Group
Traduzido por: Suporte phpBB